GPL compatible license

Because many many users ask for more capabilities I decided to use (instead of the original swf video player I made) a custom build of the JW Player which uses license CC-NC-SA 3.0 which is a non-GPL compatible license and because that It can’t be included on the WordPress directory.

From version 1.3.1 the player.swf and all the swf files are being removed and loaded externally from other server to comply with the requirements WordPress directory asks.

If you want to download a full version with all files included and without dependency on any other sites but yours the version 1.3.0 still available on my site:

http://rodrigopolo.com/about/wp-stream-video

I’ll look forward on how to finally solve this crazy issue and have a better solution for everyone in the meantime, sorry for the inconvenience but you know closed minded GPL guys are.


9 Responses to GPL compatible license

  1. Bachsau says:

    If they don’t accept it, leave them alone. Give us a download. Noone needs the wordpress directory.

  2. Dota2Hook says:

    Im with Bachsau! But i like that it is loaded on an external site anyways, so i got no problem bouth ways as long as the plugin works :D which it does on latest wordpress V!

  3. Bachsau says:

    You could even include some download code right after install, just like the original JW player does.

  4. Pingback: Tamshow International

  5. benn says:

    can’t share to facebook?

  6. Chris says:

    I’m so lost lol.. what does any of this mean?

  7. Kevin says:

    Hi, Rodrigo.

    I was thinking I had used JW Player plugin on my WordPress blog in the past with no problems. But perhaps it was your plugin instead?

    I use this code structure for each video -

    [flashvideo file=http://nameofdomain.com/wp-content/uploads/2010/08/VideoFileName.mov /]

    I have upgraded WP and the JW Player Plugin and so now the player won’t open; I just get the page with the code.

    JW player says that short code isn’t theirs. they used “JwPlayer” not “flashvideo”

    is the “flashvideo” shortcode what your plugin used? and if so, based on this thread, is there no way to use it on WordPress anymore?

    thanks.

  8. Dave says:

    Getting error required parameter flv missing

Back to Top ↑